Phantasy Garden

FedoraCoreにFirefox1.5をインストールしようかと思ったんですが、rpmねぇしtar.gzを直に使うほどLinux慣れしてないし、まぁ適当に放り込んで使ってみるかと思ったのが失敗。rpmをspecからビルドすればいいじゃん、と思う前にFirefox1.0.7をアンインストしてしまったものだから、なんか色々と面倒なことになってしまっていた。まぁ、最終的に以前に1.0.7をビルドする際に使っていたspecファイルやらなんやらがあったので、無事1.5をインストールできましたが。Windowsで調べても良かったけどね。

けど、お約束で拡張機能はたいがいが使えなくなっていたので、既に1.5対応している同系統の別拡張をインストールしたり、正式に動作確認されていないTest Versionとかをインストールしたり。こういうときに自分にそっち方面の知識がないのが辛いと思った。やっぱり独学でC++とか勉強する前に、XULとかを覚えた方が役に立つかなぁ。プログラマ志望でもないからC++が必要になる可能性も低いし、実質XULのほうが私用で使う場面が多そう。Linuxの本体までハックするならC/C++は要るんだろうけど。

そんな意味で、Piro氏の中級者がFirefoxを使うのは難しいというのが的を射ていると思う。拡張機能の対応状態等、一応情報収集していた(つもり)だから1番目はかろうじて逃れているかもしれないけど、他の中級者要件は被りまくってます。まぁ、実際4番目の状況が改善されない限り意味がなかったり。

プロファイルの使い分けを行うほど深い操作もしてないし、拡張機能をハックすることもできない中級者。これからの自分のためにも、Linux+Firefoxのハックくらいはしておけるようになりたい。

Comment

Commented by なるせ 2005-12-04 10:30:19

僕は何級者なんでしょうか(´・ω・`)

・Firefox1.5リリースときいてウハウハする。
・(一応情報を調べた上で)旧verを消し、速攻最新版をインストールする。
 同居なんて全くさせる気ナッシング。
・0.x → 1.0.x → 1.5 な時はプロファイルをさっくり消す。
 (プロファイルマネージャは知ってますが、残す気が無い…)
・拡張は4個くらいしか使ってないので再インスコはすぐできる。
 (1.0.xと同じ環境構築なんて新しいプロファイルから作り出そうとする)

まあ、問題にぶちあたったらそれをなんとかしてみよう(してみたい)という
気持ちは持ち合わせていますが(`・ω・´)
(でもハックまではいかない…。しかしながら、オライリーの本は欲しいw)
自分では中級者あたりかと思ってますが、中級者なんて単なるヘタレですな。

Commented by 悠 2005-12-05 01:52:38

>>なるせ氏
行動、思考、まったく同じ仲間キタ━━━━(゚∀゚)━━━━ッ!!

同じく問題が発生すればどうにか解決しようとしますけども、プログラム内部的な問題となると現状ではどうしようもない俺ナサケナス。ハックしたい気持ちはあれど、行動が伴ってない罠。オライリー本は欲しいねぇ。今度買ってこようかなぁ。

>中級者なんて単なるヘタレですな。
中途半端な位置づけですし。向上心もないのに初心者を馬鹿にするような腐ったミカンはヘタレだと思います。

名前:

機械的スパムを防止するための検証です。以下の画像に書かれている文字列(半角英数字)を入力してください。
Captcha Image
認証:

Information

About this website

サイト名『空想庭園』。御巫 悠が自由気ままに運営しているサイトです。役に立たないコラム書きがメインなのかもしれません。

本サイトはクリエイティブ・コモンズ表示4.0 国際ライセンスの下に提供されています。

Recent Weblog

Recent Comment

Weblog Search

Weblog Category

Friend Links